念念不忘,必有迴響

还是不要随意升级PHP版本了

  仗着Laragon的便利(PHP版本各种风骚切换),总是喜欢将本地(win)的PHP版本升级到跟官网同步,然而事实证明,在不了解大版本更新的前提下,瞎升级就是自己没事找事干!(PS:喜欢尝"鲜",却又没有去了解"鲜")😌
  关于 compact 在7.3中的"新玩法",一个自己很常用的函数。

$x = "x";
$y = "y";
$ary = compact($x,$y); // php7.2/7.3完美通过!

// 然而....
$ary = compact($x,$y,); // 7.3为什么支持了这样的写法,并且还严格的验证了变量有无正确设置 😂

  这样的坑很自然的就发生在本地一切正常,上服务器立马就挂。关键是当项目的代码"封装"的特别"好"时你还点位不到问题。WTF,多上点心吧,毕竟编程。😌

-- END

写的不错,赞助一下主机费

扫一扫,用支付宝赞赏
扫一扫,用微信赞赏
2019-08-26 16:36

就是不折腾的意思。